Raspberrypi 3B 安装 php+sqlite
分类:pc28.am神测网

按照网上的命令都为安装php5-fpm 和 php5-sqlite, 但是发现无法找到软件,可能是系统版本比较高的缘故,原来的版本已经不支持了。

安装Ubuntu Server 16.04.1 LTS

Apache

sudo apt-``get install apache2

Ubuntu 14.04 安装 LAMP 环境(apache2,mysql5.6,php5.6)

  1. 先更新下源
    sudo apt-get update
  2. 安装apache2
    sudo apt-get install apache2
    访问127.0.0.1出现apache初始页面
  3. 安装php5.6
    sudo add-apt-repository ppa:ondrej/php5-5.6
    sudo apt-get install python-software-properties
    sudo apt-get update
    sudo apt-get install php5
    sudo apt-get install php5-fpm
  4. 查看php版本
    php -v //php5.6.23
  5. 安装 mysql-client-core-5.6
    sudo apt-get install mysql-client-core-5.6
  6. mysql-client-5.6
    sudo apt-get install mysql-client-5.6
  7. 安装 mysql-server-5.6
    sudo apt-get install mysql-server-5.6

经过努力华找到如下安装方法
sudo apt-get install php-fpm (默认安装的是php7)
sudo apt-get install php7.0-sqlite3

更新安装包目录 sudo apt-get update

PHP

sudo apt-get install php5

sudo apt-get install php5-gd     //支持更高级的图片显示功能需要安装GD图形支持

让Apache支持php

sudo apt-get install libapache2-mod-php5

需要的朋友可以试一下

更新已安装的应用 sudo apt-get upgrade

MYSQL

  1. sudo apt-get install mysql-server

  2. apt-get install mysql-client

  3.  sudo apt-get install libmysqlclient-dev

安装apache

PYTHON

sudo apt-get install python2.7 python2.7-dev

sudo apt-get install apache2

Python安装MySQLdb库

sudo apt-get install build-essential libssl-dev libevent-dev libjpeg-dev libxml2-dev libxslt-dev

sudo apt-get install python-pip 
sudo apt-get install python-dev 
sudo pip install mysql-python

 

安装php5.6

安装PhpMyAdmin

$ sudo apt-get install phpmyadmin
$ sudo apt-get install php-mbstring
$ sudo apt-get install php-gettext
安装时选择自动配置数据库,输入数据库root账号的密码
如果不安装以上两个php软件包,则会报错或者白屏,提示找不到/usr/share/php/php-gettext/gettext.inc之类的错误
ln -s /usr/share/phpmyadmin /var/www/phpmyadmin    //安装完后默认的安装位置是在/usr/share 而不是在/var/www 所以要建立软链接

ubuntu上安装mysql非常简单只需要几条命令就可以完成。

  1. sudo apt-get install mysql-server

 

  2. apt-get isntall mysql-client

 

  3.  sudo apt-get install libmysqlclient-dev

 

  安装过程中会提示设置密码什么的,注意设置了不要忘了,安装完成之后可以使用如下命令来检查是否安装成功:

 

  sudo netstat -tap | grep mysql

 

  通过上述命令检查之后,如果看到有mysql 的socket处于 listen 状态则表示安装成功。

 

  登陆mysql数据库可以通过如下命令:

 

  mysql -u root -p 

 

  -u 表示选择登陆的用户名, -p 表示登陆的用户密码,上面命令输入之后会提示输入密码,此时输入密码就可以登录到mysql。 

   

  然后通过 show databases; 就可以查看当前的数据库。

  我们选择 mysql数据库就行下一步操作,使用use mysql 命令,显示当前数据库的表单:show tables 

  

  

由于Ubuntu16.04.1默认获取的php版本是php7.0,因此需要其他目录源

一、安装MySQL服务器和客户端

执行以下命令:

sudo apt-get install mysql-server-5.6 mysql-client-5.6 
sudo apt-get install libmysqlclient-dev libmysqld-dev

sudo apt-get install software-properties-common

二、Python安装MySQLdb库

执行以下命令:

sudo apt-get install python-pip 
sudo apt-get install python-dev 
sudo pip install mysql-python

验证方法:

进入Python命令行界面: 
import MySQLdb 
未报错即表示安装成功

P.S. 可使用 “apt-cache search 包名” 来查询安装包全名。

 

 

apache2,php5,mysql5都可以运行,就是phpmyadmin不能用。
本人得到的经验是:MYSQL安成功后,一定要先给它设个密码,这上步是不可少的。
此篇只代表个人的观点和经验,可能会片面化和有错误,请大家批评指正,有问题大家一起来讨论!!

1 .要用apt-get的方式安装,最好,也可能是必须先运行下面在命令升级自己的系统,我的就只能先升级后才能安装mysql5

  • Apache2 PHP5的。
    我在没升级前运行sudo apt-get install apache2 php5 mysql-server 是没有用的。而如果你找的源不好或是你的网络不稳定的话,你也有可能升级不成。这样的话,你想用apt-get的方式来安装一些软件时可能是不能安装的。
    sudo apt-get update
    sudo apt-get dist-upgrade

2.安装:
sudo apt-get install mysql-server
安装上mysql5
sudo apt-get install apache2
安装apache2
sudo apt-get install php5
安装php5
sudo apt-get install php5-mysql
安装php的mysql模块
sudo apt-get install php5-gd
安装GD库
在运行上面的命令的时候,可以留心看下libapache2-mod-auth-mysql(安装apache2时可能会安上)和libapache2-mod-php5,如果看到安上了就不用再单独安装了。

3 . 配置:

我们刚安装上的MYSQL,只有一个系统默认的root用户,而且是没有密码的,此时我们一定要给MYSQL设置一个密码root。

终端下输入:
mysql -u root -p
mysql> enter password: root

mysql>/q 退出mysql

mysql的配置文件-my.cnf:(路径:/etc/mysql/my.cnf)
运行命令:sudo gedit /etc/mysql/my.cnf可编辑。

apache2的配置文件-apache2.conf(路径:/etc/apache2/apache2.conf)
运行命令:sudo gedit /etc/apache2.conf可编辑

PHP的配置文件-php.ini:(路径:/etc/php5/apache2/php.ini)
运行命令:sudo gedit /etc/php5/apache2/php.ini可编辑。

此时这三个文件暂时不用编辑,如为了安全起见和优化,是一定要编辑的。具体的大家可参观其它资料,此篇暂不多说!!

4 . 安装phpmyadmin
sudo apt-get install phpmyadmin
安装完毕可测试: 当出来界面就行了,暂时先别登录,等改下你的PHPMYADMIN的配置文件(config.inc.php)再登陆。
终端输入:sudo gedit /etc/phpmyadmin/config.inc.php
找到$cfg['Servers'][$i]['password']= '';
改成:$cfg['Servers'][$i]['password']= 'root';
‘root‘是刚才设置的mysql的密码。

建立一个软连接:#sudo ln -s /usr/share/phpmyadmin/ /var/www/
建立一个软连接,或者你把phpmyadmin直接复制到 /var/www/的文件夹下面也可以。
在Ubuntu下面就可以正常使用phpmyadmin了。

 

5 . 此时最好重新启动计算机,(在网看到有人这样说,因是第二次安装也就照做了)打开浏览器
用户名输入root,再输入刚改的密码,然后执行
可以看到在win下那可亲的phpmyadmin面貌了。

小结:
apache2的操作命令:
启动:sudo /etc/init.d/apache2 start
重启:sudo /etc/init.d/apache2 restart
关闭:sudo /etc/init.d/apache2 stop
apache2的默认主目录:/var/www/

 

 

 

sudo add-apt-repository ppa:ondrej/php

4.1 Python的安装

ubuntu下可以很方便的使用apt-get来安装软件,这里我们安装 Python 2.7/3.2(因为Python2和Python3区别很大)。安装步骤如下(下面的命令安装了两种)。

然后更新及安装php

4.1.1 安装Python发布版本

安装Python2.7:

1 //安装 Python 发布版本,dev包必须安装,很多用pip安装包都需要编译
2 sudo apt-get install python2.7 python2.7-dev

安装Python3.2:

1 //安装 Python 发布版本,dev包必须安装,很多用pip安装包都需要编译
2 sudo apt-get install python3.2 python3.2-dev

当然,我们也可以一起安装:

1 sudo apt-get install python2.7 python2.7-dev python3.2 python3.2-dev

sudo apt-get update

4.1.2 安装build依赖包

1 //很多pip安装的包都需要libssl和libevent编译环境
2 sudo apt-get install build-essential libssl-dev libevent-dev libjpeg-dev libxml2-dev libxslt-dev

sudo apt-get install php5.6

4.1.3 安装pip

pip是Python的包管理工具,建议Python的所有包都用pip进行管理,命令如下:

1 //安装 pip
2 sudo apt-get install python-pip

(如果已安装其他版本,需先卸载然后安装,参看 )

4.1.4 安装virtualenv

virtualenv是 Python 多版本管理的利器,不同版本的开发调试全靠它了(如果没有安装不同版本的Python则不需要安装了),命令如下:

1 //安装 virtualenv
2 sudo pip install virtualenv

安装mysql

4.1.5 配置个人用virtualenv

尽量在 virtualenv 下进行 Python 包的安装。命令如下:

1 //安装 python2.7 virtualenv
2 virtualenv --no-site-packages -p /usr/bin/python2.7 ~/.venv/python2.7

以及

1 //安装 python3.2 virtualenv
2 virtualenv --no-site-packages -p /usr/bin/python3.2 ~/.venv/python3.2

然后将下面的代码增加到~/.bashrc的最后面,缺省使用 virtualenv 来代替系统 Python 环境:

1 # 缺省激活python2.7环境
2 if [ -f ~/.venv/python2.7/bin/activate ]; then
3     . ~/.venv/python2.7/bin/activate
4 fi

 

 

sudo apt-get install mysql-server

 

安装步骤

其他模板安装

 

1 apt-get install phpmyadmin 

sudo apt-get install libapache2-mod-php5.6

 

2 安装完后默认的安装位置是在/usr/share 而不是在/var/www 所以 需要将其链接到/var/www来,复制的话貌似需要改配置文件,相当麻烦。

sudo apt-get install php5.6-mysql

 

链接命令  ln -s /usr/share/phpmyadmin /var/www/phpmyadmin

sudo apt-get install php5.6-gd

 

3 在地址栏打开phpmyadmin localhost/phpmyadmin 输入帐号密码,进入页面之后你可能会发现 在左侧会出现一个错误说表不存在。如果没有出现这个错误的话,那么祝贺你安装成功。如果出现出现了请看4.

基本配置完成

 

4.出现错误的原因是数据库中并没有phpmyadmin需要的数据库,那么这就需要我们自己去添加一个数据库了。

另:改变apache默认访问目录

 

  1. install 安装的phpmyadmin 的安装文件中是没有examples 这个文件的。所以我们需要去网上找一个对应版本的phpmyadmin文件,将其下载下来解压后找到examples这个文件夹,然后找到create_tables.sql这个sql文件。复制到/var/www/下面。

默认访问目录为/var/www/html

 

6.打开mysql ,具体命令是mysql -u你的数据库用户名 -p你的数据库密码 进入数据库后 输入 source /var/www/create_tables.sql 这样就OK了。

修改为/var/www

 

 

sudo nano /etc/apache2/sites-enabled/000-default    在文档中找到 DocumentRoot 在后面修改要放置网页文件的目录(/var/www)

重启apache

sudo /etc/init.d/apache2 restart

本文由pc28.am发布于pc28.am神测网,转载请注明出处:Raspberrypi 3B 安装 php+sqlite

上一篇:ip_vs实现分析,加权调节算法的原理 下一篇:没有了
猜你喜欢
热门排行
精彩图文
  • Raspberrypi 3B  安装 php+sqlite
    Raspberrypi 3B 安装 php+sqlite
    按照网上的命令都为安装php5-fpm 和 php5-sqlite,但是发现无法找到软件,可能是系统版本比较高的缘故,原来的版本已经不支持了。 安装Ubuntu Server 16.04.1
  • 选择fdisk化解VPS上wdcp空间不足的主题素材,linu
    选择fdisk化解VPS上wdcp空间不足的主题素材,linu
    先是,我们须要效法一下碰到,下图 使用VMware为我增加一块300G(实际200M~~手动滑稽 -_-)的硬盘设备。 linux磁盘管理,linux磁盘 摘自: 查看磁盘也许目录
  • 需要编辑,安装电脑系统图
    需要编辑,安装电脑系统图
    一、硬盘安装Windows10筹划职业: 1、首先下载硬盘安装工具nt6 hdd installer nt6 hddinstaller是一款硬盘安装系统工具,客户无需依赖光驱、U盘,能够直接在存活的
  • Vim文本编辑器,Vim编辑器基础
    Vim文本编辑器,Vim编辑器基础
    Vim编辑器基础 vi:Visual Interfacevim:VI iMproved 先说目标和背景 今天布署服务器的时候,使用Linux编辑配置文件的时候,开采Vim编辑器各样不懂行。平时开掘“
  • 创建上下文菜单项,创建图标标记
    创建上下文菜单项,创建图标标记
    创建上下文菜单项  创建图标标记 Handlers(续)     1、新建一个ATL Project。 1、新建一个ATL Project。 2、建议将Project Property中Linker – General - “Register Output”设